Home » Developer & Programmer » Reports & Discoverer » Сan`t set the Source Filename (Oracle 11, Win7)
Сan`t set the Source Filename [message #641954] Fri, 28 August 2015 06:45 Go to next message
braggart
Messages: 5
Registered: August 2015
Location: Ukraine
Junior Member

Hello everybody!

In the Report Editor (mode "Layout print") I add element "Link file", then in the Property Inspector set "format of the source file" = "IMAGE" and field "Source filename" set 'C:\test.jpg'

The element "Link file" has name 'B_18' and located in the main body section in the repeating frame R_1.

When I run report then image is successfully displayed.

How to pass the parameters value (for example :Path_File) to the Source filename?
Maybe an easy question, but Google did not help to find the answer to it. Sad
Re: Сan`t set the Source Filename [message #641955 is a reply to message #641954] Fri, 28 August 2015 06:55 Go to previous messageGo to next message
Littlefoot
Messages: 21510
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
You can't do that (as far as I know) as this property can't be set programatically. I guess that - if you could do that - there would be a SRW built-in package's procedure which would do it.

However, Reports' Help says that you should put directory (or directories) that contain images you use in your reports into REPORTS_PATH environment variable. Doing so, you'll avoid necessity of hard-coding folder name in "Source filename" property. Read "Source Filename property" help topic for more information.
Re: Сan`t set the Source Filename [message #641956 is a reply to message #641955] Fri, 28 August 2015 07:10 Go to previous messageGo to next message
braggart
Messages: 5
Registered: August 2015
Location: Ukraine
Junior Member

Thanks, Littlefoot. Yes, I use REPORTS_PATH for my reports.

Which tools I can use and how to organize the transfer of PATH in the Oracle Peports to the image displayed. That`s difficulty.
Re: Сan`t set the Source Filename [message #641957 is a reply to message #641956] Fri, 28 August 2015 07:14 Go to previous messageGo to next message
Littlefoot
Messages: 21510
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
If directory that contains images is in REPORTS_PATH, then you don't have to specify directory name in "Source filename" property:
- now you have c:\test.jpg
- you'll have just test.jpg
Re: Сan`t set the Source Filename [message #641958 is a reply to message #641957] Fri, 28 August 2015 07:23 Go to previous messageGo to next message
braggart
Messages: 5
Registered: August 2015
Location: Ukraine
Junior Member

Ok, understand you!
Re: Сan`t set the Source Filename [message #641959 is a reply to message #641958] Fri, 28 August 2015 07:33 Go to previous messageGo to next message
braggart
Messages: 5
Registered: August 2015
Location: Ukraine
Junior Member

I found a solution. Added an ordinary field; source - a column in the database, reading from a file - YES, format - image.

And it worked.
Re: Сan`t set the Source Filename [message #641961 is a reply to message #641959] Fri, 28 August 2015 07:36 Go to previous message
Littlefoot
Messages: 21510
Registered: June 2005
Location: Croatia, Europe
Senior Member
Account Moderator
OK; I'm glad you solved the problem.
Previous Topic: Reports hang in the queue
Next Topic: Report Execution using command line
Goto Forum:
  


Current Time: Thu Nov 21 23:41:48 CST 2019