Home » RDBMS Server » Networking and Gateways » Connections to this server version are no longer supported (Oracle 12c)
Connections to this server version are no longer supported [message #671536] Tue, 04 September 2018 06:33 Go to next message
sss111ind
Messages: 608
Registered: April 2012
Location: India
Senior Member

Hi All,

We have migrated from Oracle 10g to 12c. There was a db link in Oracle 10g connecting to Oracle 9i which is not working now. It is throwing below error. Please help us fix it.

An error was encountered performing the requested operation:

ORA-03134: Connections to this server version are no longer supported.
03134. 00000 -  "Connections to this server version are no longer supported."
*Cause:    An attempt was made to connect to an Oracle server of older
           version.
*Action:   Please refer to documentation for more details.
Vendor code 3134



Regards,
Nathan


--moderator update: moved to the Networking and Gateways forum.

[Updated on: Tue, 04 September 2018 06:48] by Moderator

Report message to a moderator

Re: Connections to this server version are no longer supported [message #671537 is a reply to message #671536] Tue, 04 September 2018 06:37 Go to previous messageGo to next message
Bill B
Messages: 1898
Registered: December 2004
Senior Member
The only way to do this is to use a bridge database. Setup an oracle 10g database with no data in it. in this 10g database setup synonyms to point to your tables on 9g through a local database link in the 10g database. Then in your 12c database simply reference the synonym in the 10g database using a database link from 12c to 10g. This will then hop over to the 9 database to do the work.
Re: Connections to this server version are no longer supported [message #671538 is a reply to message #671536] Tue, 04 September 2018 06:47 Go to previous messageGo to next message
John Watson
Messages: 8022
Registered: January 2010
Location: Global Village
Senior Member
See this discussion,
http://www.orafaq.com/forum/mv/msg/203503/663657/#msg_663657
Those guys are pretty damn knowledgeable, so it probably is impossible to go 12 -> 9 though 9 -> 12 can work.
Re: Connections to this server version are no longer supported [message #671539 is a reply to message #671537] Tue, 04 September 2018 06:52 Go to previous messageGo to next message
Roachcoach
Messages: 1576
Registered: May 2010
Location: UK
Senior Member
Bill B wrote on Tue, 04 September 2018 12:37
The only way to do this is to use a bridge database. Setup an oracle 10g database with no data in it. in this 10g database setup synonyms to point to your tables on 9g through a local database link in the 10g database. Then in your 12c database simply reference the synonym in the 10g database using a database link from 12c to 10g. This will then hop over to the 9 database to do the work.

Just don't post questions about such a get up in the tuning section. You're off the edge of the map there matey Smile
Re: Connections to this server version are no longer supported [message #671540 is a reply to message #671536] Tue, 04 September 2018 08:11 Go to previous message
Michel Cadot
Messages: 66641
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator

See Compatibility matrices and differences between editions.


Previous Topic: listener and database versions
Next Topic: Not able to connect to Oracle(12c) to progress using Oracle database gateway(12c) for ODBC
Goto Forum:
  


Current Time: Wed Oct 16 12:45:22 CDT 2019